myPostUp (Deutsch) > Fragen, Erfahrungen, Tipps, Tricks, Wünsche

Fehlermeldung im HTML-Validator

(1/1)

eljoge:
Hallo,

ich habe folgenden Original-PostUp-Code in meine Startseite   http://www.joachimgerhard.de   eingebaut :

<!-- postup code by myPostUp.com -->
<script type="text/javascript" src="http://mypostup.com/docs/p1.php?id=mmmm&code=nnnnnnnnnnnn"></script>
<!-- end of postup code by myPostUp.com -->


und bekomme, wenn ich die Seite z.b. mit einem   http://validator.w3.org/  kontrolliere eine Fehlermeldung für diese Zeile. Das &-Zeichen vor "CODE" wird "angemeckert".

Leider enden aber meine Kenntnisse hier um den genauen Fehler zu entdecken. Kann mir vielleicht jemand sagen, woran das Problem liegt?

eljoge

Thomas:
Joachim,

Da Du XHTML verwendest – was sich übrigens nicht durchgesetzt hat – kannst Du zur Vermeidung dieser Anzeige anstatt des & die Zeichenfolge &amp; verwenden (was im Grunde nichts anders ist).

Ich habe übrigens die Codes in Deiner Meldung gelöscht, weil sie nicht unbedingt für die Veröffentlichung gedacht sind.

Gruß Thomas

P.S. Verwende bitte in Meldungen Deinen echten Namen.

eljoge:
Hallo Thomas,

vielen Dank für die schnelle Antwort. Jetzt funktioniert es einwandfrei.

Aber dafür ich werde mal über XHTML nachdenken.

Vielen Dank

Joachim

Thomas:
Hallo Joachim,

Mach Dir wegen XHTML bloß keine Gedanken. Da gibt es Webseiten, die nennen sich professionell und deren Code ist unbeschreiblich fehlerhaft (sieh nur mal n-tv.de an). Die Browser stellen alles korrekt dar und das ist letztendlich die Hauptsache. Es sei denn, Du hast viel zu viel Zeit ;).

Schönen Sonntag noch

Thomas

Navigation

[0] Themen-Index

Zur normalen Ansicht wechseln